Добро пожаловать

Версия 2005.01.01

Руководство пользователя

Copyright © Корелин И.А. 1993,2005


О программе

Программа предназначена для написания SQL запросов к таблицам DBF, для работы не требуется BDE, ADO, ODBC.

Группировка таблиц в базу данных. Группировка Баз данных в папках. Просмотр и редактирование содержимого таблиц. Подсветка синтаксиса SQL запроса. Быстрая вставка имен таблиц и полей в текст запроса. Сохрание результатов запроса в текстовый файл, Excel, HTML, DBF, XML. Поддержка подключаемых модулей (Plugin). Создание произвольных отчетов. И многое другое.


Лицензионное соглашение

DBF - SQL Expert

Лицензия, действительная только для граждан стран бывшего СССР:

Все авторские права на DBF - SQL Expert принадлежат автору.

Граждане стран бывшего СССР имеют право использовать DBF - SQL Expert бесплатно.

Автор оставляет за собой право отменить действие данной лицензии для любой из следующих версий DBF - SQL Expert.

DBF - SQL Expert распространяется свободно, при условии того, что настоящий дистрибутив не изменен. Ни одно частное лицо или организация не может брать плату за распространение программы без письменного разрешения автора.

DBF - SQL Expert поставляется по принципу "AS IS", никаких гарантий не прилагается и не предусматривается.

ВЫ ИСПОЛЬЗУЕТЕ ЭТО ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ НА СВОЙ СТРАХ И РИСК. АВТОР НЕ БУДЕТ ОТВЕЧАТЬ НИ ЗА КАКИЕ ПОТЕРИ ИЛИ ИСКАЖЕНИЯ ДАННЫХ В ПРОЦЕССЕ ИСПОЛЬЗОВАНИЯ ЭТОГО ПРОГРАММНОГО ОБЕСПЕЧЕНИЯ.

Вы не можете создавать новые версии, сдавать в наем или аренду, продавать, изменять, декомпилировать, дизассемблировать, изучать код программы другими способами, передавать зарегистрированную программу, иначе такое нелегальное использование означает автоматическое и немедленное прекращение действия настоящего соглашения и может преследоваться по закону.

Установка и использование DBF - SQL Expert означает, что вы понимаете положения настоящего лицензионного соглашения и согласны с ними.

Если почему-либо вы не согласны с этим лицензионным соглашением, вам необходимо удалить файлы дистрибутива DBF - SQL Expert с ваших устройств хранения информации и прекратить использование DBF - SQL Expert.


С чего начать

Для использования программы по прямому назначению надо:

1. Зарегистрировать Базу данных
2. Подключится к зарегистрированной Базе данных
3. Добавить DBF таблицы к активной Базе данных
4. Написать и выполнить SQL запрос

кроме того, можно просмотреть и редактировать содержание таблиц активной Базы данных

О более интересных возможностях программы смотрите раздел Дополнительные возможности, однако можно ничего не читать, а просто поэкспериментировать - в выпадающем по нажатию правой кнопкой мыши меню содержится большинство команд управления.


Регистрация Базы данных

scr51

Для регистрации Базы данных необходимо выбрать пункт меню База данных|Зарегистрировать базу или нажать клавишу F2 находясь в окне Эксплорер Баз данных и в открывшемся окне указать:

06 Наименование
Имя Базы Данных.
06 Рабочая папка
Папка, содержащая файлы связанные с Базой Данных (файлы DBF таблиц, файлы SQL запросов и т.п.).
Отключить запись Истории
При установленной опции "Отключить запись Истории" не ведется история выпоняемых запросов к Базе Данных.
Сохранять Desktop
При установленной опции "Сохранять Desktop" будет производится запись параметров всех открытых окон (их размер и положение) активной Базы Данных.
Подключить файлы из рабочей папки
Если указана рабочая папка, то при установленной опции "Подключить файлы из рабочей папки" Вы имеете возможность подключить файлы DBF таблиц расположенных в этой папке.

.


Подключение к Базе данных

Для подключения к Базе данных необходимо выбрать пункт меню База данных|Подключиться к базе или дважды кликнуть мышкой на соответствующей ветви в дереве окна Эксплорер Баз данных

Вид окна Эксплорера Баз данных после подключения

scr50


Добавление DBF таблицы

Для подключения DBF таблицы к Базе данных необходимо выбрать пункт меню База данных|Добавить... или нажать комбинацию клавишу Ctrl+F2 находясь в окне Эксплорер Баз данных и ввести параметры подключаемой таблицы.

scr34

06 Файл
Имя файла DBF таблицы.
06 Алиас
Псевдоним, который будет использоваться для идентификации таблицы при выполнении SQL запросов.
Трансляция ASCII
При установленной опции "Трансляция ASCII" транслирует значения строковых и Memo полей из ASCII в ANSI.
Использовать записи помеченные на удаление
Определяет будут ли отображаться и использоваться записи помеченные на удаление.
Открыть в режиме "только чтение"
Определяет режим работы с DBF таблицей. Режим "только чтение" запрещает пользователю модификацию и удаление данных.
Монопольное использование таблицы
Определяет каким будет доступ к DBF таблице. В случае монопольного использования при успешном открытии таблицы DBF - SQL Expert запрещает доступ к данным таблицы из других приложений.
Подсчет количества записей
Включение/выключение подсчета фактического количества записей в таблице. Для больших таблиц при включенной опции "Подсчет количества записей" возможна задержка при открытии и перемещению по таблице.
Не активизировать Таблицу
При установленной опции "Не активизировать Таблицу" таблица не активируется при подключении к Базе Данных.
Подключить не активную таблицу подключенной Базы данных можно с помощью функции [image] Подключить таблицу (Alt+A) меню главного окна программы.
Отключить активную таблицу подключенной Базы данных можно с помощью функции [image] Отключить таблицу (Alt+U) меню главного окна программы.


Дополнительные возможности

К дополнительным возможностям DBF - SQL Expert отнясятся:

· Возможность использования Подключаемых модулей сторонних разработчиков
· Возможность создания пользователем собственных отчетов


Подключаемые модули

DBF - SQL Expert начиная с версии 2.3.0.3 поддерживает технологию подключаемых модулей (Plugin).

Технику написания подключаемого модуля иллюстрирует пример, который поставляется в комплекте DBF - SQL Expert.
Ниже приведен исходный текст интерфейсного модуля.

unit DSExIntf;

interface

uses Windows;

type

(*
PlaceMenu
0 - Adds plugin menu items to the end of Main Menu | File
1 - Adds plugin menu items to the end of Main Menu | Databases
2 - Adds plugin menu items to the end of Main Menu | SQL
3 - Adds plugin menu items to the end of Main Menu | Results
4 - Adds plugin menu items to the end of Main Menu | Plugins
5 - Adds plugin menu items to the end of Main Menu | View
6 - Adds plugin menu items to the end of Main Menu | Help
*)

(* *)
PDSEPluginInfo = ^TDSEPluginInfo;
TDSEPluginInfo = record
PluginName : PChar;
// *****************************
MenuCaption: PChar;
MenuHint : PChar;
MenuSortCut: PChar;
MenuDivider: Integer; // 0-нет, 1-до, 2-после, 3-до и после
PlaceMenu : PChar;
BitmapName : PChar;
ExecProc : PChar;
ToolBarBtn : Integer; // 0 - не добавлять в панель инструментов
// *****************************
Author : PChar;
Copyright : PChar;
Description: PChar;
Version : PChar;
Created : PChar;
UpgradeSite: PChar;
end;

(* DBF - SQL Expert objects lists *)
TDSEDataBaseList = Pointer;
TDSETablesList = Pointer;
TDSETableFields = Pointer;
TDSEQuery = Pointer;
TDSEForm = Pointer;

(* Information about Database *)
PDSEDataBaseInfo = ^TDSEDataBaseInfo;
TDSEDataBaseInfo = record
Id : Integer;
Name : PChar;
WorkFolder : PChar;
Active : Boolean;
end;

(* Information about table *)
PDSETableInfo = ^TDSETableInfo;
TDSETableInfo = record
DBId : Integer;
Alias : PChar;
FileName : PChar;
Transliter: Boolean;
UseDeleted: Boolean;
ReadOnly : Boolean;
Exclusive : Boolean;
DataSet : Pointer; // TDataSet
end;

(* Information about field of table *)
PDSEFieldInfo = ^TDSEFieldInfo;
TDSEFieldInfo = record
Name : PChar;
TypeAsString: PChar;
Len : WORD;
Dec : WORD;
end;

(**)
TGetListCount = function(List: pointer): Integer;

(* Database functions *)
TGetDatabases = function: TDSEDataBaseList;
TGetDBInfo = function(Databases: TDSEDataBaseList;Index: Integer): PDSEDataBaseInfo;
TGetActiveDBInfo= function(Databases: TDSEDataBaseList): PDSEDataBaseInfo;
TFreeDatabases = procedure(Databases : TDSEDataBaseList);
TDBName = function(DBId: Integer): PChar;
TDBActive = function(DBId : Integer): Boolean;
TOpenDB = function(DBId: Integer): Integer;
TCloseDB = function(DBId: Integer): Integer;

(* Table and fields functions *)
TGetTables = function(DBId: Integer): TDSETablesList;
TTableInfo = function(Tables: TDSETablesList;Index: Integer): PDSETableInfo;
TTableInfoAlias = function(Tables: TDSETablesList;Alias: PChar): PDSETableInfo;
TFreeTables = procedure(Tables: TDSETablesList);
TFieldsOfTable = function(DBId: Integer;Alias: PChar): TDSETableFields;
TFieldInfo = function(Fields: TDSETableFields;Index: Integer): PDSEFieldInfo;
TFieldInfoName = function(Fields: TDSETableFields;Name: PChar): PDSEFieldInfo;
TFreeTableFields = procedure(Fields: TDSETableFields);

(* Query functions *)
TGetQuery = function: TDSEQuery;
TSetQuerySQL = procedure(Query: TDSEQuery;SQL: PChar);
TPrepareQuery = function(Query: TDSEQuery;var PrepareInfo: PChar) : Integer;
TOpenQuery = function(Query: TDSEQuery): Integer;
TCloseQuery = function(Query: TDSEQuery): Integer;
TExecQuery = function(Query: TDSEQuery): Integer;
TGetFieldByName = function(Query: TDSEQuery;const FieldName: PChar): Variant;
TGetFieldByIndex = function(Query: TDSEQuery;FieldIndex: Integer): Variant;
TQueryEof = function(Query: TDSEQuery): Boolean;
TQueryNext = procedure(Query: TDSEQuery);
TQueryFirst = procedure(Query: TDSEQuery);
TQueryLast = procedure(Query: TDSEQuery);
TQueryPrior = procedure(Query: TDSEQuery);

(* Interface function *)
TAddFormWinPanel = function(Form: TDSEForm): Integer;

(* Plugin interface *)
PDSEInterface = ^TDSEInterface;
TDSEInterface = record
MainApplication: Pointer;
MainScreen : Pointer;
// MainImageList : longint;

(**)
GetListCount: TGetListCount;

(* Database functions *)
GetDatabases: TGetDatabases;
GetDBInfo: TGetDBInfo;
GetActiveDBInfo: TGetActiveDBInfo;
FreeDatabases: TFreeDatabases;
DBName: TDBName;
DBActive: TDBActive;
OpenDB: TOpenDB;
CloseDB: TCloseDB;

(* Table and fields functions *)
GetTables: TGetTables;
TableInfo: TTableInfo;
TableInfoAlias: TTableInfoAlias;
FreeTables: TFreeTables;
FieldsOfTable: TFieldsOfTable;
FieldInfo: TFieldInfo;
FieldInfoName : TFieldInfoName;
FreeTableFields: TFreeTableFields;

(* Query functions *)
GetQuery: TGetQuery;
SetQuerySQL: TSetQuerySQL;
PrepareQuery: TPrepareQuery;
OpenQuery: TOpenQuery;
CloseQuery: TCloseQuery;
ExecQuery: TExecQuery;
GetFieldByName: TGetFieldByName;
GetFieldByIndex: TGetFieldByIndex;
QueryEof: TQueryEof;
QueryNext: TQueryNext;
QueryFirst: TQueryFirst;
QueryLast: TQueryLast;
QueryPrior: TQueryPrior;

(* Interface function *)
AddFormWinPanel: TAddFormWinPanel;
end;

TGetPluginInfoProc = procedure(PluginInfo: PDSEPluginInfo); stdcall;
TPluginExecuteProc = procedure(Intf: TDSEInterface); stdcall;

implementation

end.


Менеджер отчетов

Менеджер отчетов предоставляет пользователю возможность создания произвольных отчетов с использованием данных из активной Базы Данных.

Менеджер отчетов DBF - SQL Expert использует два типа отчетов:
· Fast Report
· Excel

Пользователь может использовать любой из этих типов отчетов по своему усмотрению. В примерах показана техника построения с использованием обоих типов отчетов.


Диалоги и формы

Copyright © Корелин И.А. 1993,2005


Формы

Copyright © Корелин И.А. 1993,2005


Главное окно

grepresults Главное окно

scr68
Главное окно программы содержит:

· Главное Меню
С помощью главного меню выполняются все функции программы
· Панель инструментов
На панели инструментов расположены кнопки наиболее часто используемых функций
· Панель открытых окон
Панель открытых окон позволяет управлять открытыми окнами программы
· Строку состояния
В строке состояния отображается текущие дата и время, а также индикатор выполнения SQL запроса

Файл

Параметры среды
Позволяет произвести настройку среды DBF - SQL Expert.
Параметры редактора
Позволяет произвести настройку параметров текстового редактора SQL.
visopt Визуальная настройка
Позволяет произвести настройку внешнего вида DBF - SQL Expert.
delete2 Выход
Закрывает открытую Базу Данных и завершает работу программы.

Подключаемые модули

Внешние программы
Вид
Эксплорер Баз Данных
Описание объектов
SQL редактор
Парсер
Панели инструментов
База Данных
Панель окон
Запрос
Редактор
Инструменты
Выполнение
Результат
Подключаемые модули
Помощь
help2 Содержание
tool2 Информация о подключенных модулях
Вызывает окно Информация о подключенных модулях
inf О программе
Вызывает окно О программе


Эксплорер Баз данных

В окне Эксплорер Баз данных показываются все базы данных, зарегистрированные в DBF - SQL Expert.

Папки Баз Данных
Добавить папку Alt+F2
Переименовать папку Alt+F4
Удалить папку Alt+F8
База Данных
Зарегистрировать Базу F2
Изменить регистрационную информацию F4
Удалить регистрационную информацию F8
Менеджер отчетов
blank Переместить в корень
connect Подключиться к базе Shift+Ctrl+C
Отсоединиться от базы Shift+Ctrl+D
Состав Базы Данных
createtable Создать таблицу
mstruk Изменить структуру
Добавить Ctrl+F2
prop Параметры Ctrl+F4
Удалить Ctrl+F8
Открыть таблицу Ctrl+F3
password Сменить пароль таблицы
Подключить таблицу Alt+A
Отключить таблицу Alt+U


Параметры Базы данных

Для регистрации Базы данных необходимо выбрать пункт меню База данных|Зарегистрировать базу или нажать клавишу F2 находясь в окне Эксплорер Баз данных и указать наименование базы данных и рабочую папку.

Если указана рабочая папка, то Вы имеете возможность подключить файлы DBF таблиц расположенных в этой папке. Для этого необходимо выставить галочку на переключателе Подключить файлы из рабочей папки, а затем в окне Список таблиц отметить таблицы, которые будут включены в базу данных.

06 Наименование
Имя Базы Данных.
06 Рабочая папка
Псевдоним, который будет использоваться для идентификации таблицы при выполнении SQL запросов.
Отключить запись истории
При установленной опции не производится запись истории выполнения SQL запросов.
Сохранять Desktop
При установленной опции при отключении Базы Данных сохраняется информация об открытых окнах "Просмотра и редактирования таблиц", их положении и размерах.
Подключить файлы из рабочей папки
При установленной опции и если указана рабочая папка, Вы имеете возможность подключить файлы DBF таблиц расположенных в этой папке.


Список таблиц

В этом окне Вы можете отметить таблицы, которые будут включены в Базу данных и установить параметры подключения этих таблиц:

Отметить/разотметить (установить/снять) можно с помощью клика левой клавишей мышки в соответствующей колонке таблицы или клавишами "Пробел" или Insert. Клик левой клавишей мышки на заголовке столбца устанавливает отметки выбранного столбца на все записи. Кроме того: клавиша "+"(плюс) - отмечает все записи текущего столбца; клавиша "-"(минус) снимает отметки со всех записей текущего столбца; клавиша "*"(звездочка) инвертирует отметки записей текущего столбца.

06 Файл
Имя файла DBF таблицы.
06 Алиас
Псевдоним, который будет использоваться для идентификации таблицы при выполнении SQL запросов.
Трансляция ASCII
При установленной опции "Трансляция ASCII" транслирует значения строковых и Memo полей из ASCII в ANSI.
Использовать записи помеченные на удаление
Определяет будут ли отображаться и использоваться записи помеченные на удаление.
Открыть в режиме "только чтение"
Определяет режим работы с DBF таблицей. Режим "только чтение" запрещает пользователю модификацию и удаление данных.
Монопольное использование таблицы
Определяет каким будет доступ к DBF таблице. В случае монопольного использования при успешном открытии таблицы DBF - SQL Expert запрещает доступ к данным таблицы из других приложений.
Подсчет количества записей
Включение/выключение подсчета фактического количества записей в таблице. Для больших таблиц при включенной опции "Подсчет количества записей" возможна задержка при открытии и перемещению по таблице.


Параметры таблицы

table Параметры таблицы

06 Файл
Имя файла DBF таблицы.
06 Алиас
Псевдоним, который будет использоваться для идентификации таблицы при выполнении SQL запросов.
Трансляция ASCII
При установленной опции "Трансляция ASCII" транслирует значения строковых и Memo полей из ASCII в ANSI.
Использовать записи помеченные на удаление
Определяет будут ли отображаться и использоваться записи помеченные на удаление.
Открыть в режиме "только чтение"
Определяет режим работы с DBF таблицей. Режим "только чтение" запрещает пользователю модификацию и удаление данных.
Монопольное использование таблицы
Определяет каким будет доступ к DBF таблице. В случае монопольного использования при успешном открытии таблицы DBF - SQL Expert запрещает доступ к данным таблицы из других приложений.
Подсчет количества записей
Включение/выключение подсчета фактического количества записей в таблице. Для больших таблиц при включенной опции "Подсчет количества записей" возможна задержка при открытии и перемещению по таблице.
Не активизировать Таблицу
При установленной опции "Не активизировать Таблицу" таблица не активируется при подключении к Базе Данных.
Подключить не активную таблицу подключенной Базы данных можно с помощью функции [image] Подключить таблицу (Alt+A) меню главного окна программы.
Отключить активную таблицу подключенной Базы данных можно с помощью функции [image] Отключить таблицу (Alt+U) меню главного окна программы.


Ввод пароля

Окно ввода пароля ипользуется для:
· установки пароля на открытие DBF файла
· ввода пароля для подключения и открытия DBF файла защищенного паролем.


Новая ТАБЛИЦА

newtable Новая ТАБЛИЦА

С помощью этой функции Вы можете создать новый файл DBF таблицы.

06 Папка
Имя папки, в которой будет создан файл DBF таблицы.
06 Имя
Имя файла DBF таблицы.
11 Тип DBF файла
Определяет тип создаваемой DBF таблицы.
06 Пароль
Если указан пароль, файл DBF таблицы будет зашифрован. В дальнейшем доступ к такой таблице возможен только после указания пароля.

Подключить к Базе Данных

06 Алиас
Псевдоним, который будет использоваться для идентификации таблицы при выполнении SQL запросов.
Трансляция ASCII
При установленной опции "Трансляция ASCII" транслирует значения строковых и Memo полей из ASCII в ANSI.
Использовать записи помеченные на удаление
Определяет будут ли отображаться и использоваться записи помеченные на удаление.
Открыть в режиме "только чтение"
Определяет режим работы с DBF таблицей. Режим "только чтение" запрещает пользователю модификацию и удаление данных.
Монопольное использование таблицы
Определяет каким будет доступ к DBF таблице. В случае монопольного использования при успешном открытии таблицы DBF - SQL Expert запрещает доступ к данным таблицы из других приложений.
Подсчет количества записей
Включение/выключение подсчета фактического количества записей в таблице. Для больших таблиц при включенной опции "Подсчет количества записей" возможна задержка при открытии и перемещению по таблице.
Не активизировать Таблицу
При установленной опции "Не активизировать Таблицу" таблица не активируется при подключении к Базе Данных.
Подключить не активную таблицу подключенной Базы данных можно с помощью функции [image] Подключить таблицу (Alt+A) меню главного окна программы.
Отключить активную таблицу подключенной Базы данных можно с помощью функции [image] Отключить таблицу (Alt+U) меню главного окна программы.


Изменение структуры таблицы

mstruk Изменение структуры таблицы

С помощью этой функции Вы можете изменить структуру DBF таблицы.


Редактор SQL

sqltext Редактор SQL

scr5
Текст
Редактора для ввода текста SQL запроса. Настройку параметров редактора можно определить в окне Параметры редактора

new Новый Ctrl+N
Создать новый SQL запрос. При этом, если были внесены не сохраненные изменения, то будет выведен диалог с предложением сохранения изменений.
open Открыть... Ctrl+L
Загружает в окно редактирования SQL запроса содержание текстового файла.
save Сохранить Ctrl+S
Сохраняет содержание SQL запроса в текстовый файл.
saveall Сохранить как...
Выводит диалог с запросом имени и месторасположения нового текстового файла для сохранения текста SQL запроса.
script Скрипт
Вызывает окно Выполнения скрипта.
preview Предварительный просмотр
Формирует и выводит на предварительный просмотр отчет с текстом SQL запроса.
print Печать
Формирует и выводит на печать отчет с текстом SQL запроса.
blank prev Предыдущий запрос
П
blank next Следующий запрос
П
cut Вырезать Shift+Del
П
copy Копировать Ctrl+Ins
Копирование выделенного текста SQL запроса в буфер обмена Windows.
paste Вставить Shift+Ins
Вставка содержимого буфера обмена Windows в текст SQL запроса.
blank Выбрать Все Ctrl+A
Выбор всего текста SQL запроса.
undo Отменить Ctrl+Alt+BkSp
Отмена действия последней команды редактора SQL запроса.
redo Вернуть Shift+Alt+BkSp
Отмена действия предыдущих команд ОТМЕНИТЬ.
find Поиск Ctrl+F
Производит поиск в тексте SQL запроса.
repl Замена Ctrl+R
Производит поиск и замену в тексте SQL запроса.
Искать вперед Ctrl+Alt+N
Производит поиск или замену (в соответствии с тем какая из операций выполнялась последней) от текущего положения к окончанию.
Искать назад Ctrl+Alt+P
Производит поиск или замену (в соответствии с тем какая из операций выполнялась последней) от текущего положения к началу.
fieldslist Вставить поле... F5
Вызывает окно Вставить поле и вставляет в текст запроса сформированную строку с именем поля (полей).
function Вставить функцию... Alt+F5
Вызывает окно Вставить функцию и вставляет в текст запроса сформированную строку функции.
editsql Построитель... F7
Вызывает окно Визуального построителя SQL запросов.
pre Подготовит запрос
Производит проверку текста SQL запроса.
Выполнить запрос F9
Выполняет SQL запрос.
Быстрая ставка УТВЕРЖДЕНИЯ, ФУНКЦИИ или ПОЛЯ таблицы Ctrl+Space

Результат
Данные
В этом окне выводятся результат выполнения SQL запроса.

kolumns Видимость полей
Вызывает окно Набор отображаемых полей
Экспорт
Вызывает окно Экспорта для экспортирования данных результата выполнения запроса.
Отчет
Формирует отчет из данных таблицы результатов выполнения SQL запроса.

save Сохранить
Сохраняет в файл сформированный отчет.
print Печать
Выводит на печать сформированный отчет
Масштаб
Позволяет изменять масштаб предварительного просмотра сформированного отчета.
История

Удалить утверждение
Удаляет из базы данных истории запросов текущее утверждение.
Очистить историю
Удаляет все записи из базы данных истории запросов.


Вставка поля

field Вставка поля


Вставка функции

function Вставка функции


Функции пользователя

В этом окне определяются параметры функции пользователя.

Параметры

06 Имя функции
Имя функции должно быть уникальным
11 Категория
Определяет категорию к которой будет отнесена функция пользователя
11 Тип возвращаемого результата
Определяет тип результата функции пользователя.
Допистимые типы:
String
Float
Integer
Boolean
07 Размер возвращаемой строки
Если тип возвращаемого результата функции - String, то необходимо указать максимальное количество символов в строке.
Комплексная функция
Установленный флажок означает, что функция может использовать другие функции определенные пользователем, для этого необходимо перейдя на закладку Используемые функции отметить функции, которые будут использоваться.

Редактор

Процедуры и функции

open Открыть
Загружает в окно редактирования содержание текстового файла.
save Сохранить
Сохраняет содержание окна редактированя функции пользователя в текстовый файл.
preview Просмотр
Формирует и выводит на предварительный просмотр отчет с текстом функции пользователя.
print Печать
Формирует и выводит на печать отчет с текстом функции пользователя.
find Поиск
Производит поиск в тексте функции пользователя.
repl Замена
Производит поиск и замену в тексте функции пользователя.
Искать далее
Производит поиск или замену (в соответствии с тем какая из операций выполнялась последней) от текущего положения к окончанию.
Искать назад
Производит поиск или замену (в соответствии с тем какая из операций выполнялась последней) от текущего положения к началу.

Описание

Вы можете внести описание функции пользователя в виде обычного текста или и использованием форматирования.

open Открыть
Загружает в окно редактирования описание содержание текстового файла.
save Сохранить
Сохраняет содержание описания в текстовый файл.
bld Жирный
Вставляет в текст описания в текущую позицию курсора тэги для отображения текста жирным шрифтом.
kurs Наклонный
Вставляет в текст описания в текущую позицию курсора тэги для отображения текста наклонным шрифтом.
podch Подчеркнутый
Вставляет в текст описания в текущую позицию курсора тэги для отображения текста подчеркнутым шрифтом.
percerk Перечеркнутый
Вставляет в текст описания в текущую позицию курсора тэги для отображения текста перечеркнутым шрифтом.
fontn Шрифт
Вставляет в текст описания в текущую позицию курсора тэги для отображения текста шрифтом выбранным пользователем.
vindex Верхний индекс
Вставляет в текст описания в текущую позицию курсора тэги для отображения текста в верхнем индексе.
nindex Нижний индекс
Вставляет в текст описания в текущую позицию курсора тэги для отображения текста в нижнем индексе.
paragraph Параграф
Вставляет в текст описания в текущую позицию курсора тэги Параграфа.

Полный текст

save Сохранить
Сохраняет содержание окна редактирования функции пользователя в текстовый файл.
pre Проверка синтаксиса
Производит проверку синтаксиса функции пользователя.
Выполнить
Выполняет функцию пользователя.


Значения входящих параметров

edit Значения входящих параметров

пп


Ошибка компиляции функции пользователя

errorvarning Ошибка компиляции функции пользователя

Это окно выводится в случае возникновении ошибки компиляции функции пользователя во время выполнения SQL запроса. В нем содержится информация об ошибке и указывается место ее возникновения в исходном тексте функции.


Выполнение Скрипта

script Выполнение Скрипта

Скрипт позволяет выполнить несколько SQL утверждений, разделенных точкой с запятой.

Скрипт

open Открыть... Ctrl+L
Загружает в окно редактирования SQL запроса содержание текстового файла.
save Сохранить Ctrl+S
Сохраняет содержание SQL запроса в текстовый файл.
saveall Сохранить как...
Выводит диалог с запросом имени и месторасположения нового текстового файла для сохранения текста SQL запроса.
preview Предварительный просмотр
Формирует и выводит на предварительный просмотр отчет с текстом SQL запроса.
print Печать
Формирует и выводит на печать отчет с текстом SQL запроса.
find Поиск Ctrl+F
Производит поиск в тексте SQL запроса.
repl Замена Ctrl+R
Производит поиск и замену в тексте SQL запроса.
Искать вперед Ctrl+Alt+N
Производит поиск или замену (в соответствии с тем какая из операций выполнялась последней) от текущего положения к окончанию.
Искать назад Ctrl+Alt+P
Производит поиск или замену (в соответствии с тем какая из операций выполнялась последней) от текущего положения к началу.

Утверждения

Колонки таблицы SQL утверждений

# | Порядковый номер SQL утверждения
 | Отметка на выполнение SQL утверждения Отметить/разотметить (установить/снять) можно с помощью клика левой клавишей мышки в соответствующей колонке таблицы или клавишами "Пробел" или Insert. Клик левой клавишей мышки на заголовке столбца устанавливает отметки выбранного столбца на все записи. Кроме того: клавиша "+"(плюс)- отмечает все записи текущего столбца; клавиша "-"(минус) снимает отметки со всех записей текущего столбца; клавиша "*"(звездочка) инвертирует отметки записей
BP | Отметка точки останова
Утверждение | Первая строка SQL утверждения
Ok | Статус выполнения SQL утверждения: - SQL утверждение успешно выполнено - SQL утверждение не выполнено

Выполнить F9
Выполняет все отмеченные утверждения от текущего утверждения до конца или до точки останова [image], если она выставлена к колонке BP .
Выполнить шаг F8
Выполняет одно утверждение от текущей позиции.
Прервать выполниение Ctrl+F2
Позволяет, в случае необходимости, прервать выполнение скрипта.


Просмотр и редактирование таблицы

table Просмотр и редактирование таблицы

В окне просмотра и редактирования таблицы доступны следующие функции:

Данные

edit Режим F4
Позволяет переключать таблицу в режим редактирования или просмотра.
filter Фильтр
Позволяет устанавливать фильтр на отображение данных таблицы.
sort Индекс
Позволяет подключать индексы, хранящиеся во внешних индексных файлах. Перестраивать активный индекс.
Параметры/Операции
refresh Обновить F5
Переоткрывает таблицу.
transascii Трансляция ASCII
При установленной опции "Трансляция ASCII" транслирует значения строковых и Memo полей из ASCII в ANSI.
usedeleted Использовать записи помеченные на удаление
В большинстве программ, работающих с таблицами в формате DBF, при удалении записи она не удаляется физически из файла, а специальным образом помечается, поэтому существует возможность отображать такие записи. Для физического удаления всех помеченных записей необходимо выполнить сжатие (упаковку) таблицы.
readonly Режим "Только чтение"
Определяет режим работы с DBF таблицей. Режим "только чтение" запрещает пользователю модификацию и удаление данных. Режим "только чтение" устанавливается автоматически при открытии файла таблиц с атрибутом "только чтение" (например при открытии таблицы с CD диска).
exclusive Монопольное использование
Определяет каким будет доступ к DBF таблице. В случае монопольного использования при успешном открытии таблицы DBF - SQL Expert запрещает доступ к данным таблицы из других приложений.
sum Подсчет количества записей
Включение/выключение подсчета фактического количества записей в таблице. Для больших таблиц при включенной опции "Подсчет количества записей" возможна задержка при открытии и перемещению по таблице.
repeat Восстановить удаленную запись
Восстанавливает (изменяет статус) запись "помеченную на удаление".
Восстановить Все удаленные записи
Восстанавливает Все (изменяет статус) записи "помеченные на удаление".
packt Упаковка(Сжатие) таблицы
В большинстве программ, работающих с таблицами в формате DBF, при удалении записи она не удаляется физически из файла, а специальным образом помечается. Для физического удаления всех помеченных записей необходимо выполнить сжатие (упаковку) таблицы.
correct Удалить все записи
Удаляет (помечает как удаленные) все записи открытой таблицы.
zap Очистить таблицу
Физически удаляет все записи открытой таблицы.

addrec Копировать запись
Добавляет новую запись в таблицу и копирует значение полей текущей записи в поля новой записи. Функция доступна только в режиме редактирования таблицы.
memo Редактировать Memo поле
Позволяет просматривать и редактировать, если таблица находится в режиме редактирования, поля типа: Memo, Graphic и Blob.
find Поиск Ctrl+F
Производит поиск значения поля или его части по таблице.
repl Замена Ctrl+R
Производит замену найденного значения поля или его фрагмента по таблице.
Искать вперед Ctrl+Alt+N
Производит поиск или замену (в соответствии с тем какая из операций выполнялась последней) по таблице от текущего положения к окончанию таблицы.
Искать назад Ctrl+Alt+P
Производит поиск или замену (в соответствии с тем какая из операций выполнялась последней) по таблице от текущего положения к началу таблицы.
kolumns Видимость полей
Позволяет определить набор отображаемых полей таблицы.
fontn Шрифт столбца таблицы
Позволяет установить шрифт для текущего столбца таблицы данных.
Экспорт
Позволяет экспортировать данные таблицы в файл формата:
· DBF
· MS Excel
· HTML
· TXT
· SQL скрипт
· XML

Отчет

save Сохранить
Сохраняет в файл сформированный отчет.
print Печать
Выводит на печать сформированный отчет.
blank Масштаб
Позволяет изменять масштаб предварительного просмотра сформированного отчета.

Скрипт

save Сохранить
Сохраняет текст SQL скрипта в текстовый файл.
preview Просмотр
Формирует и выводит на предварительный просмотр отчет с текстом SQL скрипта.
print Печать
Формирует и выводит на печать отчет с текстом SQL скрипта.
blank Тип SQL
Позволяет установить тип SQL, в соответствии с которым DBF - SQL Expert будет генерировать текст SQL скрипта.


Набор отображаемых полей

kolumns Набор отображаемых полей

В этом окне Вы можете определить те поля, которые будут отображаться в окне просмотра и редактирования таблицы.

Отметить/разотметить (установить/снять) можно с помощью клика левой клавишей мышки в соответствующей колонке таблицы или клавишами "Пробел" или Insert. Клик левой клавишей мышки на заголовке столбца устанавливает отметки выбранного столбца на все записи. Кроме того: клавиша "+"(плюс)- отмечает все записи текущего столбца; клавиша "-"(минус) снимает отметки со всех записей текущего столбца; клавиша "*"(звездочка) инвертирует отметки записей текущего столбца.


Фильтр

filter Фильтр


Подключение индесного файла

sort Подключение индесного файла


Редактор MEMO

memo Редактор MEMO

В этом окне Вы можете просматривать и редактировать (если таблица находится в режиме редактирования) содержание Memo поля.
Доступные операции:
· Очистить содержимое Memo поля
· Импортировать данные из текстового файла в Memo поле
· Экспортировать данные Memo поля в текстовый файл
· Копировать содержимое Memo поля в буфер обмена
· Вставлять содержимое буфера обмена в Memo поле


Редактор Изображения

03 Редактор Изображения

В этом окне Вы можете просматривать и редактировать (если таблица находится в режиме редактирования) содержание поля типа Graphic.
Доступные операции:
· Очистить содержимое Graphic поля
· Импортировать данные из графического файла в Graphic поле
· Экспортировать данные Graphic поля в графический файл
· Копировать содержимое Graphic поля в буфер обмена
· Вставлять содержимое буфера обмена в Graphic поле


Редактор Blob поля

09 Редактор Blob поля

В этом окне Вы можете просматривать информацию о Blob поле и изменять его содержимое.
Доступные операции:
· Очистить содержимое Blob поля
· Импортировать данные из файла в Blob поле
· Экспортировать данные Blob поля в файл
·


Поиск по таблице

find Поиск по таблице

В появившемся диалоге надо указать:

06 Искать что
Введите текст, который Вы хотите найти, вставьте из буфера обмена или выберите из списка.
11 Колонка
Можно установить режим поиска во всех колонках или в какой то конкретной колонке.
Чувствительность к регисту
Включение режима в котором различаются строчные и прописные буквы.
Только целые слова
Включение режима в котором выполняется поиск только целых слов.
Поиск в Memo полях
Включение режима при котором выполняется поиск в текстовых Memo полях.
10 Направление
Определяет в каком направлении будет производиться поиск: вперед от текущей строки, назад от текущей строки или с начала таблицы.

Поиск производится только по отображаемым колонкам и строкам.


Замена по таблице

repl Замена по таблице

В появившемся диалоге надо указать:

06 Искать что
Введите текст, который Вы хотите найти, вставьте из буфера обмена или выберите из списка.
06 Заменить на
Введите текст, на который Вы хотите заменить найденный фрагмент, вставьте из буфера обмена или выберите из списка.
11 Колонка
Можно установить режим поиска во всех колонках или в какой то конкретной колонке
Чувствительность к регисту
Включение режима в котором различаются строчные и прописные буквы.
Только целые слова
Включение режима в котором выполняется поиск только целых слов.
Поиск в Memo полях
Включение режима при котором выполняется поиск в текстовых Memo полях.
10 Направление
Определяет в каком направлении будет производиться поиск: вперед от текущей строки, назад от текущей строки или с начала таблицы.

Замена производится только по отображаемым колонкам и строкам и только в режиме редактирования таблицы.


Менеджер отчетов

report Менеджер отчетов

В этом окне отображаются отчеты Пользователя активной Базы Данных.

Эксплорер Отчетов
Добавить F2
Вызывает окно Параметра отчетов и если пользователь нажал кнопку OK добавляет новый отчет в эксплорер отчетов.
Свойства F4
Вызывает окно Параметра отчетов для изменения параметров отчета.
Удалить F8
Удаляет отчет из Базы Данных.
desing Дизайнер F5
Вызывает на редактирование форму отчета.
Импорт формы
Импортирует форму отчета из внешнего файла.
Экспорт формы
Экспортирует форму отчета во внешний файл.
preview Просмотр F3
Формирует отчет и выводит его на просмотр.
open Загрузить отчет Ctrl+L
Загружает отчет из внешнего файла специализированного формата.
save Сохранить отчет Ctrl+S
Сохраняет параметры и форму отчета во внешний файл специализированного формата.
Предварительный просмотр FastReport отчета
save Сохранить отчет
Сохраняет в файл сформированный отчет.
print Печать отчета
Выводит на печать сформированный отчет.
blank Масштаб
Позволяет изменять масштаб предварительного просмотра сформированного отчета.
Предварительный просмотр Excel отчета
save Сохранить отчет
Сохраняет в файл сформированный отчет.
blank Масштаб
Позволяет изменять масштаб предварительного просмотра сформированного отчета.
blank Значение текущей ячейки
Отображает значение текущей ячейки сформированного Excel отчета.


Параметры Отчета

В этом окне определяются параметры отчета Пользователя.

Общие

06 Наименование
Наименование отчета пользователя.
06 Автор
Автор отчета.
Редактировать форму отчета в Microsoft Excel
При установленной опции для редактирования формы отчета будет загружаться Microsoft Excel.
Просматривать сформированный отчет в Microsoft Excel
При установленной опции для просмотра сформированного отчета будет загружаться Microsoft Excel.
Использовать SQL запрос
При установленной опции в качестве источника данных возможно использование SQL запроса, определенного в отчете пользователя. Перед началом генерирования отчета SQL запрос будет активирован, а по окончании формирования отчета - закрыт. Если SQL запрос содержит параметры, то пользователю будет предложено указать их значения в окне Значения переменных Отчета перед открытием SQL запроса.

SQL запрос

copy Копировать SQL запрос
Копирует содержание Редактора SQL в окно редактирования SQL запроса.
open Открыть
Загружает в окно редактирования SQL запроса содержание текстового файла.
save Сохранить
Сохраняет содержание SQL запроса в текстовый файл.
preview Просмотр
Формирует и выводит на предварительный просмотр отчет с текстом SQL запроса.
print Печать
Формирует и выводит на печать отчет с текстом SQL запроса.
find Поиск
Производит поиск в тексте SQL запроса.
repl Замена
Производит поиск и замену в тексте SQL запроса.
Искать далее
Производит поиск или замену (в соответствии с тем какая из операций выполнялась последней) от текущего положения к окончанию.
Искать назад
Производит поиск или замену (в соответствии с тем какая из операций выполнялась последней) от текущего положения к началу.

Параметры

Таблица параметров содержит описание параметров SQL запроса:

Заголовок | Заголовок параметра SQL запроса, который будет выводиться в окне Значения переменных Отчета
Имя | Имя параметра SQL запроса
Тип | Тип параметра SQL запроса

Переменные

Таблица переменныех содержит описание переменных используемых в Отчете Пользователя:

Заголовок | Заголовок Переменной Отчета, который будет выводиться в окне Значения переменных Отчета
Имя | Имя Переменной Отчета
Тип | Тип Переменной Отчета

Описание

Вы можете внести описание отчета Пользователя в виде обычного текста или и использованием форматирования.

open Открыть
Загружает в окно редактирования описание содержание текстового файла.
save Сохранить
Сохраняет содержание описания в текстовый файл.
bld Жирный
Вставляет в текст описания в текущую позицию курсора тэги для отображения текста жирным шрифтом.
kurs Наклонный
Вставляет в текст описания в текущую позицию курсора тэги для отображения текста наклонным шрифтом.
podch Подчеркнутый
Вставляет в текст описания в текущую позицию курсора тэги для отображения текста подчеркнутым шрифтом.
percerk Перечеркнутый
Вставляет в текст описания в текущую позицию курсора тэги для отображения текста перечеркнутым шрифтом.
fontn Шрифт
Вставляет в текст описания в текущую позицию курсора тэги для отображения текста шрифтом выбранным пользователем.
vindex Верхний индекс
Вставляет в текст описания в текущую позицию курсора тэги для отображения текста в верхнем индексе.
nindex Нижний индекс
Вставляет в текст описания в текущую позицию курсора тэги для отображения текста в нижнем индексе.
paragraph Параграф
Вставляет в текст описания в текущую позицию курсора тэги Параграфа.


Дизайнер Exel Отчета

xlsdoc Дизайнер Exel Отчета


Новый Диапазон

new Новый Диапазон


Значения переменных Отчета

edit Значения переменных Отчета


Диалоги

Copyright © Корелин И.А. 1993,2005


Поиск

find Поиск

В появившемся диалоге надо указать:

scr57

06 Искать что
Введите текст, который Вы хотите найти, вставьте из буфера обмена или выберите из списка.
Чувствительность к регисту
Включение режима в котором различаются строчные и прописные буквы.
Только целые слова
Включение режима в котором выполняется поиск только целых слов.
От текущей позиции курсора
Включение режима в котором выполняется поиск от текущей позиции курсора.
В выделенном фрагменте
Включение режима в котором выполняется поиск только в выделенном фрагменте текста.
10 Направление
Определяет в каком направлении будет производиться поиск, вперед или назад.


Поиск и замена

repl Поиск и замена

В появившемся диалоге надо указать:

scr58

06 Искать что
Введите текст, который Вы хотите найти, вставьте из буфера обмена или выберите из списка.
06 Заменить на
Введите текст, на который Вы хотите заменить найденный фрагмент, вставьте из буфера обмена или выберите из списка.
Чувствительность к регистру
Включение режима в котором различаются строчные и прописные буквы.
Только целые слова
Включение режима в котором выполняется поиск только целых слов.
От текущей позиции курсора
Включение режима в котором выполняется поиск от текущей позиции курсора.
В выделенном фрагменте
Включение режима в котором выполняется поиск только в выделенном фрагменте текста.
10 Направление
Определяет в каком направлении будет производиться поиск, вперед или назад.


Подтверждение замены

repl Подтверждение замены


Параметры

В этом окне производится установка параметров DBF - SQL Expert.

Общие
Подавить начальный экран
Включенная опция подавляет появление начального экрана программы.
Развернуть дерево Баз Данных при запуске программы
При включенной опции дерево Баз Данных полностью разворачивается при старте программы.
Поместить значок DBF - SQL Expert на Рабочий стол
Нажатие кнопки OK при включенной опции помещает на Рабочий стол ярлычок для запуска DBF - SQL Expert.
Запретить одновременный запуск нескольких копий DBF - SQL Expert
При включенной опции невозможен запуск нескольких копий DBF - SQL Expert.
11 Язык интерфейса
Вы можете установить удобный для Вас язык интерфейса. В стандартную поставку входит один дополнительный язык - English.
Благодаря достаточно простому механизму локализации, пользователь в состоянии самостоятельно перевести интерфейс DBF - SQL Expert на нужный ему язык. При запуске DBF - SQL Expert сканирует каталог в котором располагается сам и подкаталог Language на наличие файлов языковой поддержки интерфейса, поэтому для подключения нового языка достаточно поместить новый файл языковой поддержки в один из указанных каталогов.
ndb Папки
Использовать папку Windows "TEMP" для временных файлов
При включенной опции DBF - SQL Expert будет использовать для хранения временных файлов каталог временных файлов системы.
06 Папка для временных файлов
При выключенной опции "Использовать папку Windows "TEMP" для временных файлов", для хранения временных файлов DBF - SQL Expert будет использовать указанный Вами каталог.
Подтверждения
Подтверждение выхода из редактора (если запрос был изменен)
При включеной опции DBF - SQL Expert запросит у пользователя подтверждения выхода из окна редактора SQL запроса, в случае если текст SQL запроса был изменен и не сохранен.
Подтверждение удаления объекта
При включенной опции DBF - SQL Expert запросит у пользователя подтверждения на удалении объекта (Папка Баз Данных, База Данных, Таблица, Запись, Функция пользователя, Отчет пользователя и т.п).
Подтверждение выхода из программы
При включенной опции DBF - SQL Expert запросит у пользователя подтверждения на выход из программы.
Добавление таблиц
При добавлении таблиц в Базу данных, параметры подключаемых таблиц по умолчанию будут выставлены так, как они выставлены на данной страничке.
Трансляция ASCII
При установленной опции "Трансляция ASCII" транслирует значения строковых и Memo полей из ASCII в ANSI.
Использовать записи помеченные на удаление
Определяет будут ли отображаться и использоваться записи помеченные на удаление.
Открыть в режиме "только чтение"
Определяет режим работы с DBF таблицей. Режим "только чтение" запрещает пользователю модификацию и удаление данных.
Монопольное использование таблицы
Определяет каким будет доступ к DBF таблице. В случае монопольного использования при успешном открытии таблицы DBF - SQL Expert запрещает доступ к данным таблицы из других приложений.
Подсчет количества записей
Включение/выключение подсчета фактического количества записей в таблице. Для больших таблиц при включенной опции "Подсчет количества записей" возможна задержка при открытии и перемещению по таблице.
tool1 Инструменты
SQL редактор
Открывать при подключении Базы Данных
При включенной опции при подключении Базы Данных DBF - SQL Expert откроет окно SQL редактора.
Переход на страницу "РЕЗУЛЬТАТ" при выполнении
При включенной опции в случае успешного выполнения SQL запроса активизируется страничка РЕЗУЛЬТА, в которой расположена таблица с результатами выполненного SQL запроса.
Выполнять ЗАПРОС при переходе на страницу "РЕЗУЛЬТАТ"
При включенной опции при переходе на страничку РЕЗУЛЬТАТ будет выполнен SQL запрос, текст которого находится в окне SQL редактора.
createtable Создание таблиц
При создании новых таблиц, параметры создаваемых таблиц по умолчанию будут выставлени так, как они выставлены на данной страничке.
В рабочей папке Базы Данных
При включенной опции папкой, в которой будет создана новая таблицы будет Рабочая папка текущей Базы Данных.
11 Тип DBF файла
Определяет тип создаваемой DBF таблицы.
Подключить к открытой База Данных
При включенной опции вновь созданная таблица будет подключена к открытой Базе Данных с параметрами определенными на этой страничке:
Трансляция ASCII
При установленной опции "Трансляция ASCII" транслирует значения строковых и Memo полей из ASCII в ANSI.
Использовать записи помеченные на удаление
Определяет будут ли отображаться и использоваться записи помеченные на удаление.
Открыть в режиме "только чтение"
Определяет режим работы с DBF таблицей. Режим "только чтение" запрещает пользователю модификацию и удаление данных.
Монопольное использование таблицы
Определяет каким будет доступ к DBF таблице. В случае монопольного использования при успешном открытии таблицы DBF - SQL Expert запрещает доступ к данным таблицы из других приложений.
Подсчет количества записей
Включение/выключение подсчета фактического количества записей в таблице. Для больших таблиц при включенной опции "Подсчет количества записей" возможна задержка при открытии и перемещению по таблице.
blank Создание таблиц средствами SQL
Данная группа параметром определяет значения размерности полей вновь создаваемой таблицы, если она создается с использование SQL запроса.
script Выполнение SQL скриптов
Останавливать выполнение скрипта при ошибке
При включенной опции выполнение SQL скрипта будет остановлено при возникновении ошибки в результате обработки или выполнения SQL утверждения.
tables Сетка
Все параметры вкладки Сетка действуют как на сетку данных окна Просмотра и редактирования таблицы, так и на сетку данных результатов SQL запроса.
Полосатая
При включенной опции строки сетки данных будут иметь различный цвет в зависимости от того, четная или не четная строка. Цвет четной и нечетной строки определяется на вкладке Цвета.
Показывать MEMO как ТЕКСТ
При включенной опции содержание Memo поля будут отображаться как текст.
colors Цвета
На этой вкладке определяются цвета элементов сетки данных.
fontn Шрифт
На этой вкладке определяются параметры шрифта сетки данных.
fieldf Форматы полей
На этой вкладке определяются форматы отображения в сетке полей таблицы. При установленной опции Применять размерность полей поля таблицы будут отображаться в соответствии с типом и размерностью поля. При отключенной опции Применять размерность полей поля таблицы будут отображаться в сетке в соответствии с Масками указанными на этой вкладке.
associat Ассоциации
Ассоциировать DBF - SQL Expert с DBF файлами
При включенной опции DBF - SQL Expert зарегистрирует себя в системе как программу, предназначенную для открытия DBF файлов.
Открывать DBF таблицу после коннекта "TEMP" Базы данных
DBF - SQL Expert поддерживает параметры командной строки, т.е. если в командной строке будет указано имя файла DBF таблицы, то DBF - SQL Expert создаст Базу Данных TEMP добавит к ней указанный файл и подключит TEMP Базу Данных. При включенной опции DBF - SQL Expert откроет окно Просмотра и редактирования таблицы указанного DBF файла.
Функции пользователя
Игнорировать ошибки компиляции при выполнении запроса
При включенной опции DBF - SQL Expert будет игнорировать (выдавать к качестве результата выполнения функции нулевое значение) ошибки возникающие при компиляции или выполнении функции пользователя в процессе выполнения SQL запроса, т.е. запрос будет выполнен до конца. При отключенной опции при возникновении ошибки компиляции или выполнения функции выполнение SQL запроса будет остановлено
tool2 Подключаемые модули
Подключать дополнительные модули
При включенной опции DBF - SQL Expert будет подключать дополнительные модули, если они будут обнаружены. Вы можете посмотреть информацию о подключенных дополнительных модулях в окне Информация о подключаемых модулях.
06 Папка подключаемых модулей
Определяет каталог, в котором DBF - SQL Expert будет искать дополнительные модули.
06 Имя процедуры идентификации
Определяет имя процедуры, которое будет использоваться для идентификации, инициализации и подключения дополнительного модуля. Техника разработки подключаемых модулей представлена в демонстрационном примере, входящем в стандартный комплект поставки.
gni Внешние программы
Используйте эту закладку для добавления внешних программ в меню Внешние программы главного окна DBF - SQL Expert.


Параметры редактора

В этом окне производится установка параметров Редактора.

Общие

Редактирование

Авто отступ
Позиционирует курсор под первым непустым символом предыдущей непустой строки при нажатии Enter.
Режим вставки
При включенной опции в процессе редактирования набираемый текст вставляется в позиции курсора не перезаписывая существующий текст. При отключенной опции новый набираемы текст заменяет существующий текст в позиции курсора. (Используйте клавишу Ins для переключения между режимами вставки и замены.)
Интеллектуальная табуляция

Подсветка синтаксиса
При включенной опции в редакторе производится подсветка синтаксиса. Цвета подсветки определяются на закладке Оформление.
Нумерация строк
При включенной опции производится нумерация строк введенного текста.
Позиционирование курсора за концом строки
При включенной опции возможно позиционирование курсора за фактическим концом строки.
07 Максимально число операций ОТМЕНА
Определите количество нажатий клавиши, которые могут быть отменены.
Курсор редактора
11 В режиме ВСТАВКА
Определяет форму курсора редактора в режиме ВСТАВКА.
11 В режиме ЗАМЕНА
Определяет форму курсора редактора в режиме ЗАМЕНА.
Понимание кода
Завершение кода

07 Пауза

Вид
На этой закладке определяются параметры внешнего вида редактора.

Оформление
На этой закладке определяются атрибуты текста и цвета шрифта и фона элементов SQL или PASCAL.


Визуальная настройка

visopt Визуальная настройка


Экспорт данных

type Тип
10 DBF
tables Параметры DBF
11 Тип DBF файла
Определяет тип DBF файла в который будет производится экспорт данных:
Clipper
DBaseIII
DBaseIV
FoxPro2
06 Пароль
Вы можете создать защищенный DBF файл, если будет введен пароль.
10 MS Excel
10 HTML
inet Параметры HTML
Цвет
Оформление
Пример
10 Text
textfile Параметры TXT
06 Разделитель полей
06 Текстовый разделитель
DOS кодировка
10 SQL скрипт
script Параметры SQL скрипта
06 Имя таблицы
Генерировать скрипт создания таблицы
Параметры полей типа BOOLEAN
06 Тип поля
06 FALSE
06 TRUE
10 Тип SQ
10 XML

Только видимые поля

Форматы

Файл
06 Имя
Открыть после создания
Статистика


Информация о подключаемых модулях

tool2 Информация о подключаемых модулях

DBF - SQL Expert начиная с версии 2.3.0.3 поддерживает технологию подключаемых модулей (Plugin).

В этом окне выводится информация обо всех подключенных дополнительных модулях.

Параметры подключения дополнительных модулей определяются в окне Параметры.

Технику написания подключаемого модуля иллюстрирует пример, который поставляется в комплекте DBF - SQL Expert.


О программе

inf О программе

DBF-SQL Expert
Copyright © Корелин И.А. 1993,2005
Все права защищены. (All rights reserved)

Раз Вы читаете этот текст, значит на Вашем компьютере установлена
кодовая страница WIN1251. А это в свою очередь означает, что Вы вправе
использовать этот продукт совершенно бесплатно.

Однако, используя этот инструмент в своей работе, не забывайте о том,
что в него вложен труд, и немалый. И если вдруг у Вас появятся возможность и,
главное, желание поддержать разработчика этого продукта, то я с
удовольствием приму от Вас некоторое материальное воплощение Вашей
благодарности.

В любом случае, Вы всегда можете помочь своими советами
по улучшению продукта, баг-репортами и новыми идеями.

Успехов Вам в работе!

webpage http://ileak.narod.ru
mail ilea_k@mail.ru


Форматрирование текста описания

К началу

Вы можете использовать подмножество html тэгов, чтобы сделать текст описания более привлекательным, информационным и легким для прочтения. Поддерживаются следующие HTML тэги:

<b>Пример</b> - отображение текста "Пример" жирным шрифтом.
<i>Пример</i> - отображение текста "Пример" наклонным шрифтом.
<u>Пример</u> - отображение текста "Пример" подчеркнутым шрифтом.
<strikeout>Пример</strikeout> - отображение текста "Пример" зачеркнутым шрифтом.

<p [align="left|right|center"]> - Начало нового параграфа. Параметр align определяет как будет выравниваться текст в параграфе. Значение по умолчанию - "left".

<sub>Пример</sub> - отображение текста "Пример" в нижнем индексе.

<sup>Пример</sup> - отображение текста "Пример" в верхнем индексе

<font [name="fontname"] [size="x|+x|-x"] [color={"#rrggbb"|"color name"}] [bgcolor={"#rrggbb"|"color name"}]>Пример</font> - Изменяет шрифт текста. Вы можете определить имя шрифта, размер (абсолютный размер или % увеличение, уменьшения размера), цвет шрифта и фона. Цвет должен быть шестнадцатеричной величиной в общем HTML формате или цветной идентификатор VCL (например: clWhite, clBtnFace) или цветной идентификатор HTML (например: red, black, btnshadow).

Примеры:

Исходный текст описания:

Пример отчета с использованием <b>SQL</b> запроса и передачей в отчет значений <u>переменных</u> и <u>параметров запроса</u>.

Отображение в окне описания:

Пример отчета с использованием SQL запроса и передачей в отчет значений переменных и параметров запроса.

Исходный текст описания:

<b>function <font color=blue>GetNumberStr</font></b>(<b>Number</b>: Float):String;<p>
Комплексная функция возвращает "Сумму прописью" числа<p>
В качестве вспомогательных используются функции <b>GetRSod</b> и <b>GetSod</>.

Отображение в окне описания:

function GetNumberStr(Number: Float):String;
Комплексная функция возвращает "Сумму прописью" числа
В качестве вспомогательных используются функции GetRSod и GetSod.


Языковая поддержка интерфейса

К началу

Начиная с версии 2.0.0.0, DBF - SQL Expert поддерживает MultiLanguage Interface, что позволяет использовать множество языков интерфейса. Благодаря достаточно простому механизму локализации, пользователь в состоянии самостоятельно перевести интерфейс DBF - SQL Expert на нужный ему язык.

Как перевести DBF - SQL Expert на другой язык

· Откройте любой файл *.lng в любом текстовом редакторе
· Переведите на нужный язык значения параметров (правее знака =)
· Сохраните файл под новым именем в каталог DBF - SQL Expert (или подкаталог Language)
· Выберите новый язык в настройках DBF - SQL Expert

Если вы решите перевести DBF - SQL Expert на другие языки или обнаружите ошибки и неточности в переводе - пришлите, пожалуйста, мне файлы ".lng", они будут включены в будущие версии DBF - SQL Expert.


Процедуры и функции

К началу

Standard

Function Strtointdef(s: String; def: Longint): Longint;
Function Copy(s: String; ifrom, icount: Longint): String;
Function Pos(substr, s: String): Longint;
Procedure Delete(var s: String; ifrom, icount: Longint): String;
Procedure Insert(s: String; var s2: String; ipos: Longint): String;
Function Getarraylength: integer;
Procedure Setarraylength;
Function StrGet(var S: String; I: Integer): Char;
Procedure StrSet(c: Char; I: Integer; var s: String);
Function Uppercase(s: String): String;
Function Lowercase(s: String): String;
Function Trim(s: String): String;
Function Length(s: String): Longint;
Procedure SetLength(var S: String; L: Longint);
Function Sin(e: Extended): Extended;
Function Cos(e: Extended): Extended;
Function Sqrt(e: Extended): Extended;
Function Round(e: Extended): Longint;
Function Trunc(e : Extended): Longint;
Function Int(e: Extended): Longint;
Function Pi: Extended;
Function Abs(e: Extended): Extended;
Function StrToFloat(s: String): Extended;
Function FloatToStr(e: Extended): String;
Function Padl(s: String;I: longInt): String;
Function Padr(s: String;I: longInt): String;
Function Padz(s: String;I: longInt): String;
Function Replicate(c: char;I: longInt): String;
Function StringOfChar(c: char;I: longInt): String;
Function VarGetType(x: Variant): TVarType;
Function Null: Variant;
Procedure RaiseLastException;
Procedure RaiseException(Ex: TIFException; Param: String);
Function ExceptionType: TIFException;
Function ExceptionParam: String;
Function ExceptionProc: Cardinal;
Function ExceptionPos: Cardinal;
Function ExceptionToString(er: TIFException; Param: String): String;

SysUtils

Function UpperCase(const S: String): String;
Function LowerCase(const S: String): String;
Function CompareStr(const S1, S2: String): Integer;
Function CompareText(const S1, S2: String): Integer;
Function AnsiUpperCase(const S: String): String;
Function AnsiLowerCase(const S: String): String;
Function AnsiCompareStr(const S1, S2: String): Integer;
Function AnsiSameStr(const S1, S2: String): Boolean;
Function AnsiCompareText(const S1, S2: String): Integer;
Function AnsiSameText(const S1, S2: String): Boolean;
Function AnsiStrComp(S1, S2: PChar): Integer;
Function AnsiStrIComp(S1, S2: PChar): Integer;
Function AnsiStrLComp(S1, S2: PChar; MaxLen: Cardinal): Integer;
Function AnsiStrLIComp(S1, S2: PChar; MaxLen: Cardinal): Integer;
Function AnsiStrLower(Str: PChar): PChar;
Function AnsiStrUpper(Str: PChar): PChar;
Function AnsiLastChar(const S: String): PChar;
Function AnsiStrLastChar(P: PChar): PChar;
Function Trim(const S: String): String;
Function TrimLeft(const S: String): String;
Function TrimRight(const S: String): String;
Function QuotedStr(const S: String): String;
Function AnsiQuotedStr(const S: String; Quote: Char): String;
Function AnsiExtractQuotedStr(var Src: PChar; Quote: Char): String;
Function AdjustLineBreaks(const S: String): String;
Function IsValidIdent(const Ident: String): Boolean;
Function IntToStr(Value: Integer): String;
Function IntToHex(Value: Integer; Digits: Integer): String;
Function StrToInt(const S: String): Integer;
Function LoadStr(Ident: Integer): String;
Function FmtLoadStr(Ident: Integer; const Args: array of const): String;

{ File management routines }
Function FileOpen(const FileName: String; Mode: LongWord): Integer;
Function FileCreate(const FileName: String): Integer;
Function FileRead(Handle: Integer; var Buffer; Count: Integer): Integer;
Function FileWrite(Handle: Integer; const Buffer; Count: Integer): Integer;
Function FileSeek(Handle, Offset, Origin: Integer): Integer;
Procedure FileClose(Handle: Integer);
Function FileAge(const FileName: String): Integer;
Function FileExists(const FileName: String): Boolean;
Function DirectoryExists(Name: String): Boolean;
Function ForceDirectories(Dir: String): Boolean;
Function FileGetDate(Handle: Integer): Integer;
Function FileSetDate(Handle: Integer; Age: Integer): Integer;
Function DeleteFile(const FileName: String): Boolean;
Function RenameFile(const OldName, NewName: String): Boolean;
Function ChangeFileExt(const FileName, Extension: String): String;
Function ExtractFilePath(const FileName: String): String;
Function ExtractFileDir(const FileName: String): String;
Function ExtractFileDrive(const FileName: String): String;
Function ExtractFileName(const FileName: String): String;
Function ExtractFileExt(const FileName: String): String;
Function ExpandFileName(const FileName: String): String;
Function ExpandUNCFileName(const FileName: String): String;
Function ExtractRelativePath(const BaseName, DestName: String): String;
Function FileSearch(const Name, DirList: String): String;
Function FileDateToDateTime(FileDate: Integer): TDateTime;
Function DateTimeToFileDate(DateTime: TDateTime): Integer;
Function GetCurrentDir: String;
Function SetCurrentDir(const Dir: String): Boolean;
Function CreateDir(const Dir: String): Boolean;
Function RemoveDir(const Dir: String): Boolean;

{ PChar routines }
Function StrLen(const Str: PChar): Cardinal;
Function StrEnd(const Str: PChar): PChar;
Function StrMove(Dest: PChar; const Source: PChar; Count: Cardinal): PChar;
Function StrCopy(Dest: PChar; const Source: PChar): PChar;
Function StrECopy(Dest: PChar; const Source: PChar): PChar;
Function StrLCopy(Dest: PChar; const Source: PChar; MaxLen: Cardinal): PChar;
Function StrPCopy(Dest: PChar; const Source: String): PChar;
Function StrPLCopy(Dest: PChar; const Source: String; MaxLen: Cardinal): PChar;
Function StrCat(Dest: PChar; const Source: PChar): PChar;
Function StrLCat(Dest: PChar; const Source: PChar; MaxLen: Cardinal): PChar;
Function StrComp(const Str1, Str2 : PChar): Integer;
Function StrIComp(const Str1, Str2:PChar): Integer;
Function StrLComp(const Str1, Str2: PChar; MaxLen: Cardinal): Integer;
Function StrLIComp(const Str1, Str2: PChar; MaxLen: Cardinals): Integer;
Function StrScan(const Str: PChar; Chr: Char): PChar;
Function StrRScan(const Str: PChar; Chr: Char): PChar;
Function StrPos(const Str1, Str2: PChar): PChar;
Function StrUpper(Str: PChar): PChar;
Function StrLower(Str: PChar): PChar;
Function StrPas(const Str: PChar): String;
Function StrAlloc(Size: Cardinal): PChar;
Function StrBufSize(const Str: PChar): Cardinal;
Function StrNew(const Str: PChar): PChar;
Procedure StrDispose(Str: PChar);
Function Format(const Format: String; const Args: array of const): String;
Procedure FmtStr(var StrResult: String; const Format: String; const Args: array of const);
Function StrFmt(Buffer, Format: PChar; const Args: array of const): PChar;
Function StrLFmt(Buffer: PChar; MaxLen: Cardinal; Format: PChar; const Args: array of const): PChar;
Function FormatBuf(var Buffer; BufLen: Cardinal; const Format; FmtLen: Cardinal; const Args: array of const): Cardinal;

{ Floating point conversion routines }
Function FloatToStr(Value: Extended): String;
Function CurrToStr(Value: Currency): String;
Function FloatToStrF(Value: Extended; Format: TFloatFormat; Precision, Digits: Integer): String;
Function CurrToStrF(Value: Currency; Format: TFloatFormat; Digits: Integer): String;
Function FloatToText(Buffer: PChar; const Value; ValueType: TFloatValue; Format: TFloatFormat; Precision, Digits: Integer): Integer;
Function FormatFloat(const Format: String; Value: Extended): String;
Function FormatCurr(const Format: String; Value: Currency): String;
Function FloatToTextFmt(Buffer: PChar; const Value; ValueType: TFloatValue; Format: PChar): Integer;
Function StrToFloat(const S: String): Extended;
Function StrToCurr(const S: String): Currency;
Function TextToFloat(Buffer: PChar; var Value; ValueType: TFloatValue): Boolean;
Procedure FloatToDecimal(var DecVal: TFloatRec; const Value; ValueType: TFloatValue; Precision, Decimals: Integer);

{ Date/time support routines }
Function DateTimeToTimeStamp(DateTime: TDateTime): TTimeStamp;
Function TimeStampToDateTime(const TimeStamp: TTimeStamp): TDateTime;
Function MSecsToTimeStamp(MSecs: Comp): TTimeStamp;
Function TimeStampToMSecs(const TimeStamp: TTimeStamp): Comp;
Function EncodeDate(Year, Month, Day: Word): TDateTime;
Function EncodeTime(Hour, Min, Sec, MSec: Word): TDateTime;
Procedure DecodeDate(Date: TDateTime; var Year, Month, Day: Word);
Procedure DecodeTime(Time: TDateTime; var Hour, Min, Sec, MSec: Word);
Function DayOfWeek(Date: TDateTime): Integer;
Function Date: TDateTime;
Function Time: TDateTime;
Function Now: TDateTime;
Function IncMonth(const Date: TDateTime; NumberOfMonths: Integer): TDateTime;
Procedure ReplaceTime(var DateTime: TDateTime; const NewTime: TDateTime);
Procedure ReplaceDate(var DateTime: TDateTime; const NewDate: TDateTime);
Function IsLeapYear(Year: Word): Boolean;
Function DateToStr(Date: TDateTime): String;
Function TimeToStr(Time: TDateTime): String;
Function DateTimeToStr(DateTime: TDateTime): String;
Function StrToDate(const S: String): TDateTime;
Function StrToTime(const S: String): TDateTime;
Function StrToDateTime(const S: String): TDateTime;
Function FormatDateTime(const Format: String; DateTime: TDateTime): String;
Procedure DateTimeToString(var Result: String; const Format: String; DateTime: TDateTime);
Function SysErrorMessage(ErrorCode: Integer): String;
Procedure GetFormatSettings;
Procedure Beep;
Function IsPathDelimiter(const S: String; Index: Integer): Boolean;
Function IsDelimiter(const Delimiters, S: String; Index: Integer): Boolean;
Function LastDelimiter(const Delimiters, S: String): Integer;
Function AnsiCompareFileName(const S1, S2: String): Integer;
Function AnsiLowerCaseFileName(const S: String): String;
Function AnsiUpperCaseFileName(const S: String): String;
Function AnsiPos(const Substr, S: String): Integer;
Function AnsiStrPos(Str, SubStr: PChar): PChar;
Function AnsiStrRScan(Str: PChar; Chr: Char): PChar;
Function AnsiStrScan(Str: PChar; Chr: Char): PChar;
Function StringReplace(const S, OldPattern, NewPattern: String; Flags: TReplaceFlags): String;
Function WrapText(const Line, MaxCol: Integer = 45):String;

USERS

Procedure VarExp(VarName: String; VarValue: Variant);
Procedure VarExpAdd(VarName: String; VarValue: Variant);
Function VarImp(VarName: String): Variant;
Function VarImpFloat(VarName: String): Extended;
Function VarImpStr(VarName: String): String;
Function VarImpInt(VarName: String): Integer;
Procedure VarClear;